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Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: IN-
TERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MER-
CHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical er-
rors. Changes are periodically made to the information herein; these changes 
will be incorporated in new editions of the publication. IBM may make im-
provements and/or changes in the product(s) and/or the program(s) described 
in this publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for 
this IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 

Licensees of this program who wish to have information about it for the pur-
pose of enabling: (i) the exchange of information between independently cre-
ated programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software
IBM Corporation
1 Rogers Street
Cambridge, Massachusetts 02142
U.S.A.

Such information may be available, subject to appropriate terms and condi-
tions, including in some cases, payment of a fee. 
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The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equiva-
lent agreement between us. 

Any performance data contained herein was determined in a controlled envi-
ronment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on devel-
opment-level systems and there is no guarantee that these measurements will 
be the same on generally available systems. Furthermore, some measure-
ments may have been estimated through extrapolation. Actual results may 
vary. Users of this document should verify the applicable data for their spe-
cific environment. 

Information concerning non-IBM products was obtained from the suppliers 
of those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy 
of performance, compatibility or any other claims related to non-IBM prod-
ucts. Questions on the capabilities of non-IBM products should be addressed 
to the suppliers of those products.

This information contains examples of data and reports used in daily busi-
ness operations. To illustrate them as completely as possible, the examples 
include the names of individuals, companies, brands, and products. All of 
these names are fictitious and any similarity to the names and addresses used 
by an actual business enterprise is entirely coincidental. 

If you are viewing this information softcopy, the photographs and color illus-
trations may not appear. 

Additional legal notices are described in the legal_information.html file that 
is included in your software installation.

Copyright license

This information contains sample application programs in source language, 
which illustrate programming techniques on various operating platforms. 
You may copy, modify, and distribute these sample programs in any form 
without payment to IBM, for the purposes of developing, using, marketing 
or distributing application programs conforming to the application program-
ming interface for the operating platform for which the sample programs are 
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written. These examples have not been thoroughly tested under all condi-
tions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or 
function of these programs. 

Each copy or any portion of these sample programs or any derivative work, 
must include a copyright notice as follows: 

© (your company name) (year). Portions of this code are derived from IBM 
Corp. Sample Programs. © Copyright IBM Corp. _enter the year or years_. 

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions 
worldwide. Other product and service names might be trademarks of IBM or 
other companies. A current list of IBM trademarks is available on the Web at 

www.ibm.com/legal/copytrade.html

Adobe, the Adobe logo, PostScript, and the PostScript logo are either regis-
tered trademarks or trademarks of Adobe Systems Incorporated in the United 
States, and/or other countries. 

IT Infrastructure Library is a registered trademark of the Central Computer 
and Telecommunications Agency which is now part of the Office of Govern-
ment Commerce 

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino 
logo, Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trade-
marks or registered trademarks of Intel Corporation or its subsidiaries in the 
United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other 
countries, or both. 

Microsoft, Windows, Windows NT, and the Windows logo are trademarks 
of Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the 
Office of Government Commerce, and is registered in the U.S. Patent and 
Trademark Office 

UNIX is a registered trademark of The Open Group in the United States and 
other countries. 

www.ibm.com/legal/copytrade.html
www.ibm.com/legal/copytrade.html
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marks of others.



viii IBM Rational Systems Tester 3.3 TRI Integration Tutorial April 2010

Chapter : 



April 2010 IBM Rational Systems Tester 3.3 TRI Integration Tutorial i

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM® Rational® Software Support for assistance in resolving 
product issues.

Prerequisites

To submit your problem to IBM Rational Software Support, you must have 
an active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software main-
tenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from lhttp://www.ibm.com/soft-
ware/lotus/passportadvantage/howtoenroll.htm

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at http://www.ibm.com/software/lotus/passportadvan-
tage/brochures_faqs_quickguides.html.

• For further assistance, contact your IBM representative.

• To submit your problem online (from the IBM Web site) to IBM Rational 
Software Support, you must additionally:

• Be a registered user on the IBM Rational Software Support Web site. For 
details about registering, go to http://www.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html
http://www-01.ibm.com/software/support/
http://www-01.ibm.com/software/support/
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Submitting problems

To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that 
you are reporting.

Use the following table to determine the severity level 

Severity Description

1 The problem has a critical business impact: 
You are unable to use the program, resulting in 
a critical impact on operations. This condition 
requires an immediate solution.

2 This problem has a significant business impact: 
The program is usable, but it is severely lim-
ited.

3 The problem has some business impact: The 
program is usable, but less significant features 
(not critical to operations) are unavailable.

4 The problem has minimal business impact: The 
problem causes little impact on operations or a 
reasonable circumvention to the problem was 
implemented
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2. Describe your problem and gather background information, When de-
scribing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support special-
ists can help you solve the problem efficiently. To save time, know the 
answers to these questions:

– What software versions were you running when the problem oc-
curred?

To determine the exact product name and version, use the option appli-
cable to you: 

– Start the IBM Installation Manager and select File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number. 

Start your product, and click Help > About to see the offering name and 
version number. 

– What is your operating system and version number (including any 
service packs or patches)? 

– Do you have logs, traces, and messages that are related to the 
problem symptoms? 

– Can you recreate the problem? If so, what steps do you perform to 
recreate the problem? 

– Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components? 

– Are you currently using a workaround for the problem? If so, be pre-
pared to describe the workaround when you report the problem.
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3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

– Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the elec-
tronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own 
words.

– For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html

– You can also open an online service request using the IBM Support 
Assistant. For more information, go to http://www.ibm.com/soft-
ware/support/isa/faq.html.

– By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region. 

– Through your IBM Representative: If you cannot access IBM Ra-
tional Software Support online or by phone, contact your IBM Rep-
resentative. If necessary, your IBM Representative can open a service 
request for you. You can find complete contact information for each 
country at http://www.ibm.com/planetwide/.

If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Pro-
gram Analysis Report (APAR). The APAR describes the problem in detail. 
Whenever possible, IBM Rational Software Support provides a workaround 
that you can implement until the APAR is resolved and a fix is delivered. 
IBM publishes resolved APARs on the IBM Rational Software Support Web 
site daily, so that other users who experience the same problem can benefit 
from the same resolution.

https://www.ibm.com/software/rational/support/
https://www.ibm.com/software/rational/support/
http://www.ibm.com/software/support/help.html
http://www.ibm.com/software/support/help.html
http://www-01.ibm.com/software/support/isa/faq.html
http://www-01.ibm.com/software/support/isa/faq.html
http://www.ibm.com/planetwide/
http://www.ibm.com/planetwide/
http://www.ibm.com/planetwide/
http://www.ibm.com/planetwide/
http://www.ibm.com/planetwide/
http://www.ibm.com/planetwide/
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Introduction

Purpose of this tutorial

This tutorial aims at giving the reader a hands-on experience on what is re-
quired from TRI integration and how to properly implement one. You are ex-
pected to know TTCN-3 to be able to follow the tutorial as well as having 
read Rational Systems Tester “Technical Integration Documentation” (PDF-
file found on distribution CD) and the TRI Specification. 

The tutorial will try to answer the following questions:

• What is a TRI integration? Why is it necessary and how do I implement 
it? 

• How do I create a log and plug it into the executable test suite?

• How do I develop and add encoding and decoding functions? Why is it 
necessary?

• How do I build a complete executable test suite and how do I run it?

Note
The tutorial implementation and this tutorial are made for the Windows 
platform. It should be easy however, for a skilled programmer to adopt the 
instructions and modify the implementation for a Unix or other non-Win-
dows platform.

Terminology

Often used terms in this tutorial that you should be familiar with:

ATS Abstract Test Suite

ETS Executable Test Suite 

Compiler Rational Systems Tester TTCN-3 Com-
piler

MTC Master Test Component

PTC Parallel Test Component

RTS Run-Time System

SUT System Under Test
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Files

In the text there will sometimes be references to the <tutorial_dir> direc-
tory. This is the example directory that will reside in your installation, typi-
cally for Windows this would be:

[Tester_Installation_Directory]\examples\ttcn3tutorial

TRI TTCN-3 Run-time Interface
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System overview

Goal

After this part you should understand the layout of the test system, the system 
under test (SUT), the code modules involved and how they relate to each 
other.

Abstract Test Suite and System Under Test

An Abstract Test Suite (ATS) is generally developed with the System Under 
Test in mind. The SUT has a number of potential communication channels 
(ports) through which data is transferred (a protocol). In this case the SUT is 
a separately running process which communicates through a socket. Before 
the tests are performed the communication is set up between the Executable 
Test Suite (ETS) and the SUT.

The ATS is written in TTCN-3 and as always, to be able to compile and link 
the TTCN-3 code into an executable, an integration (or adaptation) needs to 
be implemented. In this tutorial, the integration is written according to the 
TRI specification. The integration is required to handle the ports of the ATS, 
their mappings to TSI (Test System Interface) ports and the communication 
of data to the SUT over the socket.

Figure 1: ETS and SUT processes
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The gray modules in Figure 2 on page 5 are all part of the TRI integration 
implementation. The light gray ones are not strictly defined by TRI but nev-
ertheless needed to complete the integration with encoding and decoding 
functions (tut_codecs.c). The log mechanism (tut_log.c) is completely 
optional but added to show its use. The modules will be explained in more 
detail in the subsequent parts of this tutorial.

Figure 2: ATS to ETS 
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The Abstract Test Suite

Goal

In this part you will create and insert files into a TTCN-3 Project in IBM Ra-
tional Systems Tester. The analysis tool will also be used on the newly cre-
ated project.

Note
In IBM Rational Systems Tester there is an option of creating template 
projects from a set of predefined examples included with the tool installa-
tion, including the TTCN-3 tutorial example files. For the Rational Systems 
Tester tutorial, it is not necessary to copy the supplied source files any-
where since they are not supposed to be edited as part of the tutorial. If you 
choose to open a template project dialog and select the ttcn3tutorial, the 
supplied files will be copied to a project folder of your choice. The project 
and workspace files will be created from the actions described in this docu-
ment. 

TTCN-3 Project creation
Note

When running this Tutorial on Linux or Solaris platform ensure that 
OSTYPE environment variable is set to “linux” or “solaris” respectively 
before you start IBM Rational Systems Tester.

Start IBM Rational Systems Tester. In the File menu choose New and create 
a new TTCN Project and give it a proper name and location. Keep the 
Create new workspace choice selected.

Note
Ensure that path to project does not contain spaces. ASN.1 compiler may 
behave incorrectly when it’s invoked for files containing spaces in the path.

In the next dialog uncheck the Add TTCN-3 file to the project and Add 
adapter templates to the project. The reason for this is that all the neces-
sary ATS files will be added later on. Click Next and then Finish to finalize 
the project creation.

Now that you have yourself a new empty project it is time to bring the ATS 
files into the project.
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Add files to the project

In the Workspace view (the area on the left side), choose the File View by 
clicking that tab at the bottom. Now you should see the Tutorial.ttp project 
appear.

Right-click on the project and choose New Folder. Create a folder named 
ATS Files, in the File extensions field enter: *.ttcn; *.asn

Right-click the new folder ATS Files folder and choose Insert files. Add 
the TesterTutorial.ttcn, TT.ttcn and TesterTutorial.asn files 
from the <tutorial_dir> directory. The Workspace should now look 
likeFigure 3 on page 7. 

Analyze the test suite files

Now all the ATS files have been added to the project. Save All by clicking 
the icon on the tool bar or selecting the entry in the File menu. Finally click 
the Analyze button (check box symbol) or the entry in the Project menu. The 

Figure 3: Workspace File View
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analysis should go through without problems, warnings or errors. The default 
settings for analysis are sufficient. Go to the Project menu, open the Settings 
dialog. The settings are found in TTCN-3 and ASN.1 tabs.
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Test behavior

Goal 

This part shows the purpose of the test cases and what is communicated be-
tween the ETS and the SUT during test execution. 

In the test suite there are three test cases, one using asynchronous communi-
cation only (TC1a), one that uses synchronous communication (TC2s) and 
the last one (TCTimer) uses timers without any communication whatsoever.

Look at test case TC1a

Open the TesterTutorial.ttcn file and locate the test case definition named 
TC1a. 

This test case requests the SUT to perform two operations on supplied oper-
ands. One operation is requested by the PTC and the second by the MTC. 
Below is a picture that shows how the message sequence goes:

Figure 4: Sequence diagram of TC1a 
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The picture shows what happens in this test case. A PTC is created to perform 
a request to the SUT to calculate the “square” operation on a value, it verifies 
the returned result and signals to the MTC that it went fine and then it termi-
nates. After the MTC detects that the PTC operation is finished it requests the 
SUT to perform an equality operation on an integer value and a bit string 
value and then the test is finished.

Look at test case TC2s

Open the TesterTutorial.ttcn file and locate the test case definition named 
TC2s. 

This test case is somewhat simpler but instead involves synchronous commu-
nication. Below is a picture that shows how the message sequence goes:

The picture shows what happens in this test case. The SUT initiates a call to 
the MTC which returns an integer value converted from the bit string argu-
ment. The same operation is then done in the other direction with a hex string 
value after which the test is finished.

Figure 5: Sequence diagram of TC2s
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Look at test case TCTimer

Open the TesterTutorial.ttcn file and locate the test case definition named 
TCTimer. The test case is simple to explain without a picture. The MTC starts 
both its timers (T1 and T2) and waits for them to time out in the specific order 
T1 followed by T2. This test sets the requirement for the timer implementa-
tion that it can handle multiple timers. More about the timer implementation 
is explained in “Integration implementation” on page 14.
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Communication and Ports

Goal

This part shows the communication between the test and the SUT and the 
role of the ports. 

The SUT presents four ports through which communication can be per-
formed. They are called P0-P3. The SUT ports have different roles and pur-
poses. The port roles are described for each of the test cases.

Port mappings of TC1a

Open the TesterTutorial.ttcn file and look at the port definitions of the com-
ponent type MyMTCa on which test case TC1a runs. It has two ports; 
MTC2TSIport and MTC2PTCport.

As can be seen in the component and port type declarations, the TSI port P0 
is used by the MTC and the P1 port is used by the PTC. 

Figure 6: Port mappings of TC1a
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Port mappings of TC2s

Open the TesterTutorial.ttcn file and look at the port definitions of the com-
ponent type MyMTCs on which test case TC2s runs. It has three ports: 
MPortIn, MPortOutand MPortInit.

The MPortInit-P0 port mapping is used for asynchronous initialization sig-
naling and the MPortIn-P2 and MPortOut-P3 mappings are is used for syn-
chronous communication.

Figure 7: Port mappings of TC2s
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Integration implementation

Goal

This part shows what is required from a TRI integration implementation, 
which functions need to be implemented and how. After this part you will 
have built a TTCN-3 Project with both ATS files and the necessary TRI 
based integration.

Code modules

The implementation code is divided into five different code modules (with 
separate C header files):

• testertutorial_tri.c
This is the main integration file which implements the necessary TRI 
functions. The next step covers the functions in this file.

• tut_comm.c
This contains the helper functions for composing and decomposing the 
information sent between the ETS and the SUT over the socket. 

• tut_ports.c
This contains the representation and helper functions for port mappings. 

• tut_codecs.c
This contains the required encoding and decoding functions for the used 
types. There is only codecs support for the built-in TTCN-3 types used in 
the test suite; boolean, integer, bitstring and hexstring. Note that 
the ASN.1 types already have the codecs set for them, automatically gen-
erated by the Compiler. 

• tut_log.c
This is contains the log mechanism developed for the tutorial. It is cov-
ered in “Run the ETS” on page 21. 

Add the integration files to the project

Make sure you have the File View tab active in the Workspace view. Right-
click on the project and choose New Folder. Create a folder named 
Integration Files, in the File extensions field enter: *.c; *.h 
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Right-click the new Integration Files folder and choose Insert files. 
Add the C files listed above from the <tutorial_dir> except tut_log.c, 
together with their respective header files. tut_log.c file, containing the 
new log mechanism, will be added in the next part. Note that the 
testertutorial_tri.c file has no header file. The project should now 
look something like below, the order of the files are not important:

In-depth look at TRI TE-SA functions

Now it’s time to look at the TRI integration of this tutorial. There are a 
number of functions that needs to be implemented and they are covered 
below, going through each one of them. Some functions are not implemented 
in this tutorial, namely the triRaise, triSUTActionInformal and 
triSUTActionTemplate functions as well as all functions with MC and BC 
suffixes that implement multicast and broadcast communication operations.

Figure 8: Workspace TRI file view. 



16 IBM Rational Systems Tester 3.3 TRI Integration Tutorial April 2010

Chapter 2: Rational Systems Tester TRI Integration

Open the testertutorial_tri.c file to look at the TRI functions. First the 
TE->SA functions:

• triSAReset 

This function is invoked in the initialization phase of the ETS execution, 
before any TTCN-3 test code has been executed. In this tutorial it per-
forms three tasks; it initializes the socket communication, it creates the 
protection for the port representation and finally it creates the socket 
reader thread.

• triExecuteTestcase 

This function is invoked before each test case is started. In this imple-
mentation it ensures that port representation structures are cleared.

• triEndTestcase

This function is invoked at the end of each test case and usually performs 
cleanup actions. In this implementation the only thing that is necessary is 
clearing the port representation.

• triMap 

Each time a map statement is encountered, this function is called. It can 
also be called implicitly if you have not specified a system component for 
your test case. This is not exemplified in the tutorial, see the TTCN-3 
standard specification for information on this. 

In this implementation a new mapping is created and stored in a list of 
ports. 

• triUnmap 

The unmap statement is not used in the ATS for this tutorial but this func-
tion is still implemented for symmetry reasons. 

In this implementation the mapping is removed from the list of ports. 

• triSend, triCall, triReply

These are the communication functions of TRI. All these functions works 
in the same way since in TRI, even the synchronous operations of 
call/reply are made asynchronous. The synchronous behavior is handled 
completely by the RTS.
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• triSendMC, triSendBC, triCallMC, triCallBC, triReplyMC, triReplyBC, 
triRaise, triRaiseMC, triRaiseBC (not implemented) 

These functions are not implemented for this tutorial. It is analogous to 
the previous functions and can be implemented by the interested user.

Functions with MC and BC suffixes correspond to multicast and broad-
cast versions of communication operations.

• triSUTActionInformal, triSUTActionTemplate (not implemented) 

These simple functions are not implemented for this tutorial. Their pur-
pose and actions are completely test suite and SUT dependent. They have 
no meaning in this tutorial.

In-depth look at TRI PA-SA functions

There are two different ways of implementing timers. One is a passive 
scheme, where timer status is polled by the RTS and the other is active, 
where timeouts are signaled through the triTimeout function. The imple-
mentation for this tutorial is the active one since that is the approach sug-
gested by TRI. To instruct the ETS to use this scheme, the boolean configu-
ration key t3rt.timers.assuming_all_active must be set to true.

Then we have the timer related functions 

• triPAReset 

This function is called once, before the control part of the root module is 
executed. In our case we simply initialize the timer representation.

• triStartTimer 

This is called whenever a timer is explicitly started in the ETS. Note that 
implicit timers, like when you specify a timeout value on execute or call 
statements, will not trigger this function, it is dealt with in a different 
way. See the reference documentation for more details. The design here 
is to create a new thread for each new timer and after it has slept for the 
appropriate amount of time it generates its own timeout. 

• triStopTimer 

This is called when a timer is explicitly stopped by the TTCN-3 code 
using the stop statement. 

• triReadTimer 

This is called when a timer is explicitly read by the TTCN-3 code using 
the read statement.
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• triTimerRunning 

This is called when a timer is explicitly checked by the TTCN-3 code 
using the running statement.

• triExternalFunction (not implemented) 

This is called when an externally declared function is called from the 
ETS. No such functions are used in this tutorial so it is left unimple-
mented.
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Build the ETS

Goal

In this part you will generate a makefile for the tutorial and build an execut-
able test suite. 

Select configuration

This tutorial uses configurations to store settings for different platforms and 
compilers. Before continuing select the configuration that best matches your 
environment either with the project toolbar or with the Project->Configura-
tions... dialog.

Prepare makefile generation

The configuration for the makefile generation usually is defined using 
“Makefile Options“ dialog on “Build“ tab in project settings. 

Open the Project->Settings dialog and bring up the Build tab. Press “Make-
file Options...“ button. Makefile Options window opens. As you may see 
window has several tabs. Typically you need to use General and Adapter 
tabs only.

Open Adapter tab. Check that the “Libraries” entry control contains:

• t3tri on Linux

• t3tri,socket on Solaris

• libt3tri.lib,WS2_32.lib on Windows.

Note

C files that are put into project are assumed to be adapter files (unless they 
are excluded from build) thus there is not need to specify them in “Source 
files“ entry control.

Settings in the dialog

Open the Project->Settings dialog and bring up the Build tab. In the Root 
Module field, write TutorialModule which is the name of the top module 
for the tutorial test suite. In the Test management choose “Static using RTS 
functions in ETS.“
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Compile the test suite

Now push the Compiler button or choose Project->Compiler from the 
menu. The code is generated together with a proper makefile 
(makefile_TRI.mak). IBM Rational Systems Tester automatically sets the 
makefile name in the project settings to makefile_TRI.mak.

Build the ETS

Open the Project->Settings, in the Build tab and ensure that 
makefile_TRI.mak is set for the Makefile field.

Press the Build toolbar button or the Project->Build menu entry and the 
Compiler invokes the make command on the makefile and the ETS is built.

In your directory you should now have a file named TutorialModule.exe 
which is your finished ETS.
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Run the ETS

Goal

Run the test executable including how to set module parameters and to add 
your own log mechanism. 

Related documentation: “Execution Logs” (PDF on CD)

The SUT must be started before the ETS is executed. This is due to the fact 
that it acts as a server form a socket point-of-view and the tutorial ETS needs 
to connect to it. 

Start the SUT

From command-line, run the <tutorial_dir>/tutorial_sut.exe. 

> tutorial_sut.exe [-p <portnr>]

The default port number is 30000 and doesn’t have to be changed unless it 
collides with another process on your machine. If the port number is changed 
on the SUT side, it also has to be modified on the ETS side. 

The SUT is running properly when it says: 

SUT: Tutorial SUT is running.
Start the tutorial ETS.

Execution switch

The test is using generated codecs for the ASN.1 types. The SUT uses the 
standardized BER encoding and the ETS will of course need to use the same-
codec. The selection of codec can be controlled through applying a switch. 

If the codec is not specified, the test will end in error due to missing en-
coder/decoder function. 

Run ETS from Rational Systems Tester

From the Project menu, select Settings. Go to the Execution tab. Switches 
shall be given in the Additional execution switches field under the Execu-
tion tab in the Settings dialog. 

Apply the following switch:
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-confbool t3asn.ExtASN.BER.DEFINITE-LENGTH true

All keys passed to RTS should be declared inside -t3rt "" command line 
parameter key:

-t3rt "-confbool t3asn.ExtASN.BER.DEFINITE-LENGTH true"

Check Assume timers in TRI are implemented as “active”. This sets 
t3rt.timers.assuming_all_active key.

Note
Switches can also be supplied in a configuration file specified in the 'Op-
tional configuration file' field. For your convenience, there is a file named 
TesterTutorial.conf in the tutorial directory that contains the appropriate 
codec switch.

In the Execution tab ensure that TutorialModule.exe executable is set for 
the Executable test binary field. Select the TesterTutorial.conf configuration 
file for the Optional configuration file field. The dialog should look some-
thing like this (here, assuming your directory is C:\tutorial):

Figure 9: Settings for ETS execution
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Now push the Execute button and the test should run. The execution log is 
written in the output window of Rational Systems Tester. See the documen-
tation on “Execution Logs” (PDF on CD). 

See also

“ASN.1 Encoding” on page 1346 in Chapter 36, Creating an ETS

“Configuration Files” on page 1373 in Chapter 38, Execute Tests

Run the ETS from command-line

From the command-line, go to your project directory. 

All keys passed to RTS should be declared inside -t3rt "" command line 
parameter key. Apply the following switches:

-t3rt "-confbool t3asn.ExtASN.BER.DEFINITE-LENGTH true 
-confbool t3rt.timers.assuming_all_active true"

Command line switches can also be supplied in a configuration file. For your 
convenience, there is a file named TesterTutorial.conf in the tutorial direc-
tory that contains the appropriate codec switch, you can use it like this:

> TutorialModule.exe -t3rt "-file TesterTutorial.conf" 

The ETS can be invoked with no other special switches unless you have 
changed the SUT socket port number. To change port number on ETS side 
use “t3rt.tutorial.sut_port <integer key>”. For example to assign 
port #12345 add -t3rt "-confint t3rt.tutorial.sut_port 12345" 
to ETS command line parameters. 

See also

Chapter 38, Execute Tests in IBM Rational Systems Tester help. 

Logging

The logging of the test execution is based on log events generated by the 
TTCN-3 RTS. New log mechanisms can be plugged in to the RTS to fill the 
need for special logging formats and destinations (for example a database). 
For information on how to develop a log mechanism, see the “Technical in-
tegration information” documentation (PDF on CD).
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The log mechanism module in this tutorial is logging the events of the test 
execution into separate HTML files, one per component. It also generates an 
index page over the generated files. The files are all named tut-<hhmmss>-
n.html and the index file is named tut-<hhmmss>-index.html (<hhmmss 
>= time stamp).

Add the log module

Add the tut_log.c file from the <tutorial_dir> directory into your 
project in the Integration Files folder. This will automatically add it to the list 
of adapter files in the generated makefile.

Rebuild and run the ETS again

Redo the following to run the tutorial again: 

• “Compile the test suite” on page 20 

• “Build the ETS” on page 20 

• “Start the SUT” on page 21 

• “Run ETS from Rational Systems Tester” on page 21 or “Run the ETS 
from command-line” on page 23 

Make sure that any previous SUT or ETS process is terminated.

Module parameters

The main TTCN-3 module (TutorialModule) has a module parameter 
called MPar1 declared in the test suite as:

modulepar { integer MPar1 := 5 };

This value is used as argument to the Square operation involved in the TC1a 
test case. To override the default value for this parameter, a new value can be 
given on the command-line with a switch or through a module parameter 
input file. The notation for using a direct switch is:

>TutorialModule.exe -t3rt "-par Mpar1 10"

and notation for module parameters file is:

>TutorialModule.exe -t3rt "-parfile 
tut_parfile.modparams"

Where the tut_parfile.modparams should contain the entry:
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MPar1 := 8;

ETS with different module parameter values

Try these two different ways of overriding the module parameter while going 
through “Run the ETS” on page 21 again. Remember that the 
TesterTutorial.conf file must still be given as argument to the ETS.
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Food for thought
In this section some points are made about the implementation of this tutorial 
and how it might differ from a more realistic situation. 

Separate communication channels

All communication with the tutorial SUT is made using one channel (socket) 
only. This is how the SUT has been defined, the design with only one socket 
is chosen for readability reasons. 

In another situation it might be that the SUT uses separate communication 
channels for each port. This would mean that the port representation must 
keep the channel stored in each port mapping, which is a simple thing to im-
plement. It would also mean that each communication channel needs to be 
checked for incoming data, either by having a separate thread for each 
channel or having the (equivalent of the)  tut_socket_reader function to 
trigger communication on all known channels. 

More PTCs

There is no limitation in the implementation if a test involves multiple PTCs. 
The TC1a test case creates one PTC. This PTC communicates with the SUT 
and only when it is finished, the MTC communicates with the SUT. Two 
threads are running but they communicate over the same socket at different 
times. 

The implementation uses local variables only and uses a single call to the 
socket send function so it is safe. 

Timer limitations

The timer implementation is not multi-thread safe and has a limitation on the 
number of timers. It works currently since the only component that is exe-
cuting any behavior is the MTC. If multiple components should use timers, 
the list would have to be protected with a mutex and the list would most prob-
ably have to be dynamic in size. This is quite straightforward and is left for 
the interested reader to implement.
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