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Chapter 1. Introduction

IBM®Rational® Programming Patterns for System z® is installed on the IBM
Software Delivery Platform.

IBM Rational Programming Patterns for System z is constituted of a:
v Client, integrated with IBM Rational Developer for System z V8.0.3 and IBM

Rational Team Concert™ V3.0.1.
v Server, integrated with IBM Jazz™ Team Server V3.0.1.

Before installing IBM Rational Programming Patterns for System z, you must
install the products it is integrated with.
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Chapter 2. Installation road map

The installation road map lists the high-level steps for installing your product.

Procedure
1. Verify that your computer meets the minimum hardware and software

requirements for installing the client environment: Rational Developer for
System z and Rational Team Concert. See the Rational Developer for System z
site (http://www-01.ibm.com/software/rational/products/developer/
systemz/) (select one of the three product editions and select System
requirements) and the Rational Team Concert site (http://www-01.ibm.com/
software/rational/products/rtc/sysreq/index.html).

2. Verify that the computer where the Jazz Team Server will be installed meets
the minimum hardware and software requirements. See the Rational Team
Concert site (http://www-01.ibm.com/software/rational/products/rtc/
sysreq/index.html).

3. Verify that the computer where Rational Programming Patterns for System z
will be installed meets the minimum hardware and software requirements.
These requirements are listed on the Rational Programming Patterns for
System z site (http://www-01.ibm.com/software/rational/products/
programming/systemz/sysreq/).

4. Verify that VisualAge® Pacbase 3.5 V07 minimum is installed. This version
contains all the extraction and migration procedures of the VisualAge Pacbase
data.

5. Install or update the Rational Developer for System z V8.0.3 client.
6. Install or update the Rational Team Concert V3.0.1 client for Eclipse IDE

driver in the same package group as Rational Developer for System z V8.0.3
cClient.

7. Install or update the Rational Programming Patterns for System z client in the
same package group as the Rational Developer for System z V8.0.3 and
Rational Team Concert V3.0.3 clients.

8. Install or update the Jazz Team Server and CCM Application V3.0.1 .
9. Install or update the Rational Programming Patterns for System z server

where the Jazz Team Server and CCM Application V3.0.1 are already installed.
10. Perform the post-installation tasks. You must integrate Rational Programming

Patterns for System z with Rational Team Concert.
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Chapter 3. Installing the required product prerequisites

Installing VisualAge Pacbase 3.5 V07 is the first prerequisite. Then you must install
Rational Developer for System z V8.0.3 and Rational Team Concert V3.0.1 before
installing the Rational Programming Patterns for System z client. You must also
install Jazz Team Server and CCM Application V3.0.1 before installing the Rational
Programming Patterns for System z server.

Before you begin

To install the product prerequisites, you must refer to their installation guides.

Note: The installation of Rational Programming Patterns for System z is in many
ways similar to the installation of Rational Developer for System z. This
installation guide then contains references to the Rational Developer for System z
Installation Guide. You must then have access to both guides to install Rational
Programming Patterns for System z.

Procedure
1. To obtain VisualAge Pacbase 3.5 V07, send an email to the Rational

Programming Patterns for System z support (vapacsup@us.ibm.com for North
America or vapacsup@fr.ibm.com for all other regions).

2. Install or update the product prerequisites for the Rational Programming
Patterns for System z client:
a. Rational Developer for System z V8.0.3 client. Three installation packages

are available: Rational Developer for System z with EGL V8.0.3, Rational
Developer for System z with Java V8.0.3, and Rational Developer for
zEnterprise V8.0.3. Rational Programming Patterns for System z can be
installed on any of them.

Important: When installing the Rational Developer for System z client, do
not clear any of the features selected by default on the Features page of
Installation Manager.

b. Rational Team Concert V3.0.1 client. You can install it from its installation
disk or electronic image. But you can also install it as an optional feature to
the Rational Developer for System z V8.0.3 client.

Important: The Rational Team Concert V3.0.1 client must be installed in the
same package group as the Rational Developer for System z V8.0.3 client.

3. Install or update the Jazz Team Server and CCM Application V3.0.1.

Note: Installing the Rational Developer for System z host components is not
required for using the Rational Programming Patterns for System z server.
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Chapter 4. Installation methods for Rational Programming
Patterns for System z

Four installation methods are available.

You can install Rational Programming Patterns for System z from:
v an installation disk.

With this method, you have the physical disks containing the installation files,
and you install Rational Programming Patterns for System z on your own
workstation.

v a downloaded electronic image on your workstation.
With this method, you download the installation files from IBM Passport
Advantage® and you install Rational Programming Patterns for System z on
your own workstation.

v a downloaded electronic image on a shared drive.
With this method, you place the electronic image on a shared drive so that users
in your company can access the installation files of Rational Programming
Patterns for System z from a single location. It is also useful when you must
install in silent mode on several user systems.

v a repository on an HTTP server.
You can place the Rational Programming Patterns for System z installation
package, the Rational Developer for System z package, and the Rational Team
Concert package, in a single directory on HTTP Web server. This directory is
named a repository.
To place the installation files on an HTTP Web server, you must use a utility
application: IBM Packaging Utility. This application is provided with the
Developer for System z installation media on the Rational Enterprise
Deployment disk. For more information, see the Rational Developer for System z
Installation Guide, Appendix C IBM Packaging Utility.
See also the Rational Developer for System z Installation Guide, Chapter 5. Installing
Developer for System z. subchapter Installation tasks summary, section Overview:
Installing Developer for System z from a repository on an HTTP Web server and
Overview: Placing Developer for System z on an HTTP Web server.

Note on the installation in silent mode:

If you install from an electronic image or a repository, you can run Installation
Manager in silent mode to install Rational Programming Patterns for System z. You
can then use a batch process to install, update, modify, and uninstall packages
through scripts. If you are an administrator, it enables you to customize the
installation on the developers' workstations.

When you run Installation Manager in silent mode, its user interface is not
available. So you use a response file instead to input the commands required to
install the package. An install.xml sample response file is available in the
InstallerImage_win32 subdirectory of the client and in the InstallerImage_system
subdirectory (where system is aix, linux_s390, or win32) of the server. You can use
it as is or modify it to your own specifications.
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8 IBM Rational Programming Patterns for System z Version 8.0.3: Installation Guide



Chapter 5. Installing the Rational Programming Patterns for
System z client

You can install the Rational Programming Patterns for System z client on Windows
Vista, Windows XP Professional, or Windows 7 Professional, You can perform a full
installation from the launchpad. If you have already installed a previous version,
you can also update it from the IBM update server or from a compressed file
downloaded from Fix Central.

Before you begin

Rational Developer for System z V 8.0.3 and Rational Team Concert V3.0.1 clients
must already be installed

The Rational Programming Patterns for System z client must be installed with the
same type of right (administrator or user) as the Rational Developer for System z
V 8.0.3 and Rational Team Concert V3.0.1 clients

Installing the Rational Programming Patterns for System z client
You can fully install the Rational Programming Patterns for System z client from a
disk, an electronic image, or a repository.

Before you begin

Select the most appropriate installation method:
v An installation disk.

Insert the installation disk into your DVD drive.
To start installing, open the Rational Programming Patterns for System z
launchpad.
If autorun is enabled on your system, the launchpad program automatically
opens. If autorun is not enabled, start the launchpad program by running the
launchpad.exe command from the root of the disk:

v An electronic image on your workstation.
Download the installation files from IBM Passport Advantage. Extract the
installation image from the compressed files you have downloaded
To start installing, open the Rational Programming Patterns for System z
launchpad.
You start the launchpad program by running the launchpad.exe command from
the root of the extracted directory

v An electronic image on a shared drive, if you are an administrator.
Download the installation files from IBM Passport Advantage. Extract the
installation image from the compressed files you have downloaded
To install interactively from the installation files on the shared drive, run the
launchpad.exe command from the root of the extracted directory.
You can also install in silent mode. For explanations, see the note in the
Chapter 4, “Installation methods for Rational Programming Patterns for System
z,” on page 7

v A repository on an HTTP Web server, if you are an administrator
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For explanations, see the Chapter 4, “Installation methods for Rational
Programming Patterns for System z,” on page 7

Procedure
1. If you install from the Rational Programming Patterns for System z launchpad,

select Install Rational Programming Patterns for System z to open Installation
Manager.
The repository location information is automatically configured. So you do not
have to set it manually in the Installation Manager preferences.

2. The first page of the Install Packages wizard displays the Rational
Programming Patterns for System z package available for installation. Select it.

3. You might be prompted to update IBM Installation Manager to a newer version
if one is available. If prompted, click Yes to install the update, or click No if
you want to install the newer version later. If you click Yes, Installation
Manager updates itself and informs you that it must restart to complete the
update. Click OK to restart Installation Manager

4. On the Licenses page, read and accept the license agreement for the selected
package. The product will be installed with a trial license which expires in 60
days. You will need to activate the licensed version of the product in order to
use it after the expiration date.

5. On the Location pages, the location which already contains the Rational
Developer for System z V8.0.3 and Rational Team Concert V3.0.1 clients must
be selected.

6. On the Features pages, select the languages you want to install for this package
group. Select also the functions you want to install.

7. On the Summary page of Installation Manager, click Install.

Results

When the installation is complete, an IBM Rational Programming Patterns for
System z start line is created from Start → All Programs → IBM Software Delivery
Platform. You can then create a shortcut on your desktop to easily start Rational
Programming Patterns for System z.

If you start Rational Programming Patterns for System z directly from its start line
or its desktop shortcut, the 'Pattern Driven Programming' perspective is
automatically added to your workspace and it becomes the default perspective.
The PDP editors also become the default editors.

What to do next

Important: To be able to import very large databases, you must modify the
memory parameter of the Software Delivery Platform. Its maximum value varies
according to the operating system and the memory available. You must then find
the maximum value for your configuration. To do so, edit the eclipse.ini file
located directly under the root of your Software Delivery Platform. Start replacing
-Xmx1024m with -Xmx1236m. If this value is accepted, increase it progressively
until you reach the maximum value accepted by your configuration.

Updating the client from the IBM update server
You should perform the installation using the same Windows account that
originally installed the IBM Rational Programming Patterns for System z product.
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Procedure
1. Start IBM Installation Manager by selecting, by default, Start → All Programs →

IBM Installation Manager → IBM Installation Manager.
2. If the option Search service repositories during installation and updates is

selected in the preferences (menu File → Preferences), you can perform the
update. Select this option if it has been cleared.

3. On the Start page of Installation Manager, click Update. The update wizard
opens up.

4. On the 'Update packages' page, select the package which already contains the
previous version of the Rational Programming Patterns for System z client
(IBM Software Development Platform by default). Click Next.

5. Update Installation Manager, if necessary.
6. Select IBM Rational Programming Patterns for System z and its version

(Version 8.0.3). Select any other required or optional updates from the list of
available updates. Any updates you have already installed are displayed in
grey and are not be selectable. Click Next.

7. Read and accept the license agreement. The product will be installed with a
trial license which expires in 60 days. You will need to activate the licensed
version of the product in order to use it after the expiration date. Click Next

8. Select the features to be updated and click Next.
9. Review your selections on the Summary page. If you want to make any

changes to your selections, click Back and make your changes. When you are
ready to install the update, click Update.

Results

When the installation is complete, an IBM Rational Programming Patterns for
System z start line is created from Start → All Programs → IBM Software Delivery
Platform. You can then create a shortcut on your desktop to easily start Rational
Programming Patterns for System z.

If you start Rational Programming Patterns for System z directly from its start line
or its desktop shortcut, the 'Pattern Driven Programming' is automatically added
to your workspace and is becomes the default perspective. The PDP editors also
become the default editors.

What to do next

Important: To be able to import very large databases, you must modify the
memory parameter of the Software Delivery Platform. Its maximum value varies
according to the operating system and the memory available. You must then find
the maximum value for your configuration. To do so, edit the eclipse.ini file
located directly under the root of your Software Delivery Platform. Start replacing
-Xmx1024m with -Xmx1236m. If this value is accepted, increase it progressively
until you reach the maximum value accepted by your configuration.

Updating the client from a compressed file
Ideally, this update should be installed directly from the IBM update server.
However, you may also download a compressed file containing the update and
perform local installations.
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About this task

You might want to do this if
v You have a slow or unstable Internet connection and want to use a download

manager that can resume the download.
v You have difficulty accessing the live IBM update servers from behind a firewall.
v You prefer to download the update and install it later.

Procedure
1. Connect to the IBM Fix Central site.

a. Select the Rational product group, Rational Programming Patterns for
System z product, 8.0.3 version, and Windows platform. Click Next.

b. Select 'Show fixes that get me to this version' and click Next.
c. Select 'IBM Rational Programming Patterns for System z Version 8.0.3' and

click Next.
d. Select your download option and click Next.
e. Click 'Download now'.

2. Extract the content of this file to a folder on your system.
3. Start IBM Installation Manager by selecting, by default, Start → All Programs →

IBM Installation Manager → IBM Installation Manager.
4. From the menu bar, select File → Preferences to specify the location of the

extracted file.
5. On the Repositories page, click Add Repository . Browse to the directory where

you extracted the update installation files. Inside that directory you will see a
repository.config file. Select it and click OK.

What to do next

Now that the local repository has been set, follow the instructions outlined in the
section 'Updating the client from the IBM update server'.
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Chapter 6. Installing the Rational Programming Patterns for
System z server

You can install the Rational Programming Patterns for System z server either on
Windows 2003 or 2008, AIX®, Linux, Linux for System z, or on z/OS®.

Before you begin

Jazz Team Server V3.0.1 must already be installed

The Rational Programming Patterns for System z server must be installed in the
same package group as the Jazz Team Server V3.0.1 with the same type of right
(administrator or user).

Installing the server on Windows, AIX, Linux
You can install the Rational Programming Patterns for System z server on
Windows 2003 or 2008, AIX, Linux, or Linux for System z. You can perform a full
installation from an installation CD or an electronic image. If you have already
installed a previous version, you can also update it from the IBM update server or
from a compressed file downloaded from Fix Central.

Procedure
v To install the Rational Programming Patterns for System z server on Windows

2003 or 2008, AIX, Linux, or Linux for System z, you must choose between the
following methods:
– Insert its installation disk into your DVD drive.
– Download its electronic image from the IBM Passport Advantage Web site

and extract all the compressed files. If you are an administrator, you can
make them available on a shared drive.

– Install a repository on an HTTP Web server, if you are an administrator.
For explanations, see the Chapter 4, “Installation methods for Rational
Programming Patterns for System z,” on page 7

The contents of the installation disk and the extracted electronic image are the
same:
– A docs directory, with relevant documentation.
– A distributed directory which contains:

- A disk1 subdirectory, with the Rational Programming Patterns for System z
server repository.

- Four InstallerImage_system subdirectories, where system is aix,
linux_s390 (Linux for System z), linux_x86 or win32 (for Windows). These
subdirectories contain the repository for Installation Manager and the
executable files of the Rational Programming Patterns for System z server,
adapted to the operating system.
Each of these directories also contains an install.xml sample response file
for the installation in silent mode.

- For UNIX, the installRPPz_system_admin.sh and
installRPPz_system_user.sh script files, where system is aix, linux_s390
(Linux for System z) or linux_x86. Each of these scripts starts the
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installation of the Rational Programming Patterns for System z server,
according to the selected operating system. The installation is automatically
carried out from Installation Manager, with administrator or user rights,
with all the preferences and selections already entered for you.

- Two batch command files installRPPz_win32_admin.bat and
installRPPz_win32_user.bat, which start the Rational Programming
Patterns for System z server installation on Windows. The installation is
automatically carried out from Installation Manager, with administrator or
user rights, with all the preferences and selections already entered for you.

To perform a standard installation, run:
– One of the script files for Windows 2003 or 2008, AIX, Linux, or Linux for

System z (installRPPz_system_admin.sh or installRPPz_system_user.sh).
– The installRPPz_win32_admin.bat or installRPPz_win32_user.bat file for

Windows 2003 or 2008.
To specify your own installation selections, install the server from one of the
four subdirectories (InstallerImage_system). Open Installation Manager, enter
the path to the Rational Programming Patterns for System z server repository
and select your preferences on all the Installation Manager pages.

v To update the Rational Programming Patterns for System z, you must use either:
– the IBM update server. Follow the instructions of the client installation. Only

the steps where you must select a choice specific to the server installation are
indicated here.
- Select the package group in which you installed the previous version of the

IBM Rational Programming Patterns for System z server (Jazz Team Server
by default).

- Select IBM Rational Programming Patterns for System z Version 8.0.3 -
Server part.

– or a compressed file downloaded from Fix Central. Follow the instructions of
the client installation. Select IBM Rational Programming Patterns for System
z Version 8.0.3 - Server part.

Installing the server on z/OS
To install the Rational Programming Patterns for System z V8.0.3 server on z/OS,
you must apply the V8.0.3 PTF on the server already installed.

Procedure
1. To obtain the files required to install the Rational Programming Patterns for

System z server on z/OS, you must:
v Insert its installation disk into your DVD drive.
v Or download its electronic image from the IBM Passport Advantage Web site

and extract all the compressed files. If you are an administrator, you can
make them available on a shared drive.

The contents of the installation disk and the extracted electronic image are the
same:
v A docs directory, with the relevant documentation.

This directory contains the HAIE801.pdf Program Directory. It contains all the
instructions to install the Rational Programming Patterns for System z server
on z/OS, through SMP/E.

v A zos directory which contains:
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– a compressed file for the installation through SMP/E. This file contains
the installable parts:
- IBM.HAIE801.F1.BIN,
- IBM.HAIE801.F2.BIN,
- IBM.HAIE801.JCL.BIN

- IBM.HAIE801.SMPMCS.
– the V8.0.1.2 and V8.0.3 PTFs.

2. If you install the server on z/OS for the first time, follow the instructions of the
HAIE801.pdf Program Directory, located in the docs directory.

3. Update the server by applying the V8.0.1.2 PTF (UK71657), if it has not already
been done. Then apply the V8.0.3 PTF (UK73640).
These fixes are shipped as files: IBM.HAIE801.UXXXXXX.

Note: UXXXXXX is the fix number. In the steps listed below, you must replace it
with its actual value.
You must execute the following steps to install the fix:
a. Allocate host data sets for the fix

A sequential data set must be allocated on the z/OS system to receive the
fix that you will upload from your workstation. You can do this by
submitting the job below. Add a job card and modify the parameters to
meet your site's requirements before submitting.
//ALLOC EXEC PGM=IEFBR14
//*
//UXXXXXX DD DSN=hlq.IBM.HAIE801.UXXXXXX,
// DISP=(NEW,CATLG,DELETE),
// DSORG=PS,
// RECFM=FB,
// LRECL=80,
// UNIT=SYSALLDA,
//* VOL=SER=volser,
//* BLKSIZE=6160,
// SPACE=(TRK,(103,20))
//*

b. Upload the fix from your workstation to z/OS
Upload the file in binary format from your workstation to the z/OS data
set. On a Windows system, you can use FTP from a command prompt to
upload the file. The table shows the commands entered by the user, and the
values which are assumed:

User enters: Values

mvsaddr TCP/IP address of the z/OS system

tsouid Your TSO user ID

tsopw Your TSO password

d: Your drive containing the fix files

hlq High-level qualifier that you used for the
data set that you allocated in the job above

C:\>ftp mvsaddr
Connected to mvsaddr.
220-FTPD1 IBM FTP CS %version% at mvsaddr, %time% on %date%.
220 Connection will close if idle for more than 60 minutes.

User (mvsaddr:(none)): tsouid
331 Send password please.
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Password: tsopw
230 tsouid is logged on. Working directory is "tsouid.".

ftp> cd ..
250 "" is the working directory name prefix.

ftp> cd hlq
250 "hlq." is the working directory name prefix.

ftp> binary
200 Representation type is Image

ftp> put d:\IBM.HAIE801.UXXXXXX
200 Port request OK.
125 Storing data set hlq.IBM.HAIE801.UXXXXXX
250 Transfer completed successfully
5744800 bytes sent in 0.28 seconds

ftp> quit
221 Quit command received. Goodbye.

c. Perform SMP/E RECEIVE and APPLY for the fix
d. If you used the @pathPrefix@ setting during SMP/E installation, edit the

file below to ensure the file URL points to the absolute path of the
application rpp-update-sites:
@confPath@/ccm/provision_profiles/rpp-profile.ini
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Chapter 7. Post-installation tasks

Integrating with Rational Team Concert
Rational Programming Patterns for System z is now installed on top of IBM
Rational Team Concert. You must configure Rational Team Concert in order to
integrate Rational Programming Patterns for System z with it.

About this task

The purpose of this integration is to prepare the building of indexes in the Rational
Programming Patterns for System z server. You must:
v Ensure that the user has the permissions required for the configuration,
v Create a project area (if it has not already been done),
v Create three language definitions and associate indexing scanners to them,
v Select the data streams which will be scanned.

Procedure
1. Create a user and assign permissions to this user:

a. Start the Jazz Team Server and open its setup wizard
(https://[fully-qualified hostname]:9443/jts/setup)
Follow all the steps explained in the Rational Team Concert documentation:
Running the setup wizard

b. Create a user, if it has already been done.
c. Assign this new user a Developer for IBM Enterprise Platforms Client

Access License.
d. Stop the Jazz Team Server and start it again.
e. Verify that the created user has all the repository permissions and the

Developer for IBM Enterprise Platforms Client Access License.
2. Create a project area:

a. Log on to the server, at:
https://[fully-qualified hostname]:9443/ccm

as this user.
b. Create a project area.

Note: Explanations about project areas can be found in the Rational Team
Concert information center.

3. Verify the access permissions:
To create the language definitions for the Rational Programming Patterns for
System z artifacts, you must have the appropriate access permissions.
a. Open the project area by right-clicking it in the Team Artifacts tab, and

selecting Open.
b. Open the Process Configuration tab of the project area. Expand Project

Configuration in the Configurations tree and select Permissions. In the
Permitted actions tree, select Language Definitions and Source Code Data.

© Copyright IBM Corp. 2011 17

http://publib.boulder.ibm.com/infocenter/clmhelp/v3r0m1/index.jsp?topic=/com.ibm.jazz.install.doc/topics/t_s_server_installation_setup_wizard.html
http://publib.boulder.ibm.com/infocenter/clmhelp/v3r0m1/index.jsp
http://publib.boulder.ibm.com/infocenter/clmhelp/v3r0m1/index.jsp


c. Save.
4. Create the language definitions and select the associated scanners:

You can now create three language definitions:
v RPP Design,
v RPP Design Path,
v RPP Generated.
a. Expand the project area in the Team Artifacts tab. Then expand Enterprise

Extensions → System Definitions → z/OS. Right-click Language Definitions
and select New Language Definition. The Language Definition editor
opens up. It contains a General tab and a Scanners tab.

Figure 1. The Process Configuration tab
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b. Create the language definition for the design artifacts.
1) In the General tab:

v Enter RPP Design in the Name field.
v Enter an optional description, such as RPP Design File Scanner, in

the Description field.
v Select COBOL in the Language field.
v Enter the following file extensions in the File Extensions field:

dataaggregate,dataelement,dataunit,pacblockbase,pacdialog,pacscreen,
pacdialogserver,pacserver, paclibrary,pacmacro,pacprogram,pacreport,
pactext,metaentity,userentity,metadataaggregate,metaentitytype

Important: Only these file extensions are used by Rational
Programming Patterns for System z. Wildcards cannot be used.

2) In the Scanners tab, remove the default scanner and add the RPP Design
Scanner for this language definition.

3) Save.
c. Create the language definition for the design path artifacts.

1) Select New Language Definition again.
2) In the General tab:

v Enter RPP Design Path in the Name field.
v Enter an optional description, such as RPP DesignPath File Scanner,

in the Description field.
v Select COBOL in the Language field.
v Enter the following file extension in the File Extensions field:

designpath

Figure 2. The Language Definition editor
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Important: Only this file extension is used by Rational Programming
Patterns for System z. Wildcards cannot be used.

3) In the Scanners tab, remove the default scanner and add the RPP
DesignPath Scanner for this language definition.

4) Save.
d. Create the language definition for the generated artifacts.

v Select New Language Definition again.
v In the General tab:

– Enter RPP Generated in the Name field.
– Enter an optional description, such as RPP Generated File Scanner, in

the Description field.
– Select COBOL in the Language field.
– Enter the following file extensions in the File Extensions field:

cblpdp,bmspdp,mappdp,mfspdp

Important: Only these file extensions are used by Rational
Programming Patterns for System z. Wildcards cannot be used.

– In the Scanners tab, remove the default scanner and add the RPP
Generated File Scanner for this language definition.

– Save.
5. Associate data streams with the language definitions:

Specify which streams are to be scanned. In the Team Artifacts tab, under
Enterprise Extensions, right-click Source Code Data. Then click Select streams
for scanning. Specify the stream.
If you cannot see any steam, you must create one before selecting it. Follow the
instructions of 'Creating steams' in the Rational Team Concert documentation.

Figure 3. How to access the stream selection wizard
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Results

The configuration steps are now finished.

When you deliver a project which contains Rational Programming for System z
artifacts, the artifacts will be indexed, after the indexing process has been manually
or automatically activated. You will then be able to perform searches on the server
repository.

Managing licenses
If you have a trial license and if you need to configure a permanent or fixed term
license, you must indicate it after the installation.

See the Rational Developer for System z Installation Guide, Chapter 6 Post-installation
tasks, subchapter Managing licenses.

Accessing the help
By default, the help accessed by Rational Programming Patterns for System z after
its installation is the remote help, which requires an Internet connection. However
you can choose to install the help locally in order to see it without any Internet
connection, or to install it on an intranet server.

To know how to change the way you access the help, see the Rational Developer for
System z Installation Guide, Chapter 6 Post-installation tasks, subchapter Remote or
Web-based helps, section Changing the way that you access help content.

When all the help-related tasks are performed, you will be able to see the help by
selecting Help → Help contents.

Accessing Web-based help

By default, Rational Programming Patterns for System z is configured to access the
remote help from the product infocenter, located at:

http://publib.boulder.ibm.com/infocenter/rppzhelp/v8r0/index.jsp

Open Rational Programming Patterns for System z. This address must be enabled
in the table displayed when you select Window → Preferences → Help → Content.

If it is not, click New. Enter the name and address of the Rational Programming
Patterns for System z information center. Then click Enable.

Downloading help content

You can download the help from the:
v IBM Local Help System Updater website.

Open Rational Programming Patterns for System z.. Select Help → Local Help
Updater, and select Rational Programming Patterns for System z in the list of
sites.
If it is not listed, you must add it.
1. Select the 'Internal sites' filter in the list.
2. Click the + icon.
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3. Select Remote. Enter the product name and the following address:
http://publib.boulder.ibm.com/infocenter/rppzhelp/v8r0/site/site.xml

4. Select the location you just created. Expand it and select the nested lines.
5. Click Install. The help content is downloaded and installed.
The files will be updated automatically when an Internet connection is available.

v Local help updater program, without an Internet connection.
1. Extract the content RPPz803_updateSite.zip file, located in the docs directory

of the installation disks and images.
2. Open Rational Programming Patterns for System z. Select Help → Local Help

Updater.
3. Select the 'Internal sites' filter in the list.
4. Click the + icon
5. Select Local. Enter the product name. Select the fully qualified path to the

site.xml file located in the extracted content. Click OK

6. Select the internal site you created Expand it and select the nested lines
7. Click Install.
8. When the installation is complete, close and restart Rational Programming

Patterns for System z.
9. Select Window → Preferences → Help → Content. Verify that the local

infocenter is enabled. Close the Preferences window.

Setting up an intranet server for help content

You can set up an intranet server behind a firewall to provide help content to
users. With this method, users do not have to download and save help content to
their computers.

To know how to set up an intranet server for help content, see the Installation
Manager information center. Select Enterprise installation articles → Delivering
help content from an intranet server.
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Notices

© Copyright IBM Corporation 2000, 2011.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted
by GSA ADP Schedule Contract with IBM Corp.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
3-2-12, Roppongi, Minato-ku, Tokyo 106-8711 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
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Intellectual Property Dept. for Rational Software
IBM Corporation
20 Maguire Road
Lexington, Massachusetts 02421-3112
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Trademarks and service marks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at www.ibm.com/legal/
copytrades.html.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other product and service names might be trademarks of IBM or other companies.
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