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This guide provides 
information about using the 
Source Control Management 
(SCM) application in IBM® 
Rational® Integration Tester, 
including how to install 
additional plugins to enable the 
synchronisation of Rational 
Integration Tester projects with 
various source control 
management (SCM) systems. 
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Intended Audience 
This document is intended for users who are familiar with Rational Integration Tester 
and the SCM applications with which they intend to synchronize. 

Scope 
This document is about Rational Integration Tester and its built-in SCM application – 
it does not discuss specific SCM applications (for example, CVS, SVN, and so on). If 
you wish to familiarize yourself with such technologies, please refer to the 
documentation that is provided by the relevant companies or individuals. 

Typographical Conventions 
The following typographical conventions are observed throughout this document: 

Type Usage 

Constant Width Program output, listings of code examples, file names, 
commands, options, configuration file parameters, and literal 
programming elements in running text. 

Italic Document title names in statements that refer you to other 
documents. Also used to highlight concepts when first 
introduced. 

Bold Menu items in graphical user interface windows (such as 
Microsoft Windows-based or UNIX X Window applications) from 
which you select options or execute macros and functions. 

Submenus and options of a menu item are indicated with a 
“greater than” sign, such as Menu > Submenu or Menu > 
Option. 

Contacting IBM Support 
To contact IBM Support, see: www.ibm.com/contact/us/en/ 
© Copyright IBM Corp. 2001, 2012 v 
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This chapter provides 
information about using 
Rational Integration Tester’s 
SCM application to manage 
projects. 
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1.1 SCM and Rational Integration Tester 
Utilizing source control management (SCM) with Rational Integration Tester is a 
reliable way to share projects among multiple users without having to manually 
provide version control and rollback capabilities. 

Support for different SCM systems is provided by the installation of Eclipse Team 
Provider plug-ins. Support for CVS is enabled by default. If you wish to share and 
synchronize projects by means of another team provider, you will have to install it. 

The following chapters provide information about how to access the source control 
features in Rational Integration Tester. Additionally, an example of how to add the 
features of another team provider is included. 
© Copyright IBM Corp. 2001, 2012 2 
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This chapter provides 
information about sharing a 
Rational Integration Tester 
project with the SCM 
application, and describes the 
basic functionality of the tool. 
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2.1 Check In a Project 
After Rational Integration Tester has been installed, you can immediately start using 
the source control features of the product. 

NOTE:	 You may wish to review the IBM Rational Integration Tester Getting 
Started Guide or the IBM Rational Integration Tester Reference Guide (or at 
least have them available for reference) to learn more about getting 
started with Rational Integration Tester and projects. 

This section provides information about how to share an existing Rational 
Integration Tester project. For information about how to use the SCM application 
while working in your project, see Using the SCM Application. 

Follow the steps below to share a Rational Integration Tester project using the SCM 
application. 

NOTE:	 The example illustrated in the following steps utilizes an SVN 
repository, enabled with the Subclipse Team Provider. See Team 
Providers for more information about adding different providers. 

1.	 Launch Rational Integration Tester and create a new project or open an existing 
project. 

2.	 Select Source Control from the File menu. 
© Copyright IBM Corp. 2001, 2012 4 



 

 
 

3.	 If no other providers are installed (that is, only CVS), the CVS repository location 
window is displayed. If additional providers are available, however, you can select one 
and click Next. 

NOTE:	 If the current project has already been shared by means of source 
control, the project will be displayed in the GH Tester Tools window 
(see step 12). 

NOTE:	 If you need to add support for another team provider, click Cancel 
and refer to Team Providers. 

NOTE:	 Depending on the selected provider, you must configure the 
connection to an existing repository using the screens provided (they 
differ for each provider). The remaining steps in this example 
illustrate how to share the project using the SVN (Subclipse) provider. 
© Copyright IBM Corp. 2001, 2012 5 



4. Select whether you want to create a new repository location or use an existing 
location, then click Next. In this example, the new location is selected. 

5. Enter the repository URL or select from the list of recently used URLs, then click 
Next. 
© Copyright IBM Corp. 2001, 2012 6 



     

 

6. Select whether you want to use the project name as the folder name in the repository 
or a new (specified) name, then click Next. 

7. When the project is ready to share, you can enter any desired comments or select 
from any previously entered comments, then click Finish. 
© Copyright IBM Corp. 2001, 2012 7 



 

 

 

  

8. If prompted, you can enter an SVN author name for the new project, then click OK 
to proceed. 

When finished, the GH Tester Tools window is displayed and the shared project is 
shown under the Synchronize tab. 

9. Expand the project folder to see all of the components that it contains. 

The icon indicates an outgoing change in a component (that is, the updated item 
has not yet been committed to the repository). 

10. Click the Commit All Outgoing Changes icon  to commit the project to the 
repository. 
© Copyright IBM Corp. 2001, 2012 8 



 

11. In the Commit dialog, enter any desired comments and click OK. 

NOTE: The entire project should be committed because selecting individual 
components could cause problems. 
© Copyright IBM Corp. 2001, 2012 9 



  12. Once the project is committed and checked in, it is displayed in the GH Tester Tools 
window. 
© Copyright IBM Corp. 2001, 2012
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2.2 Check Out a Project 
While a project can be checked out from the SCM application, such projects should 
be opened by using the Fetch Project from Source Control option when starting 
Rational Integration Tester. 

For more information, refer to IBM Rational Integration Tester Reference Guide. 
© Copyright IBM Corp. 2001, 2012 11 



 

   

 
 

 

 
  

 

  

2.3 Using the SCM Application 
The SCM application is run in the GH Tester Tools window, available from the File 
> Source Control menu option. 

This section describes the available features in the application, including how to work 
in projects between Rational Integration Tester and the SCM application. 

By default, four views are displayed in the SCM application – Synchronize, Navigator, 
Console, and History. Other views can be displayed by selecting Window > Show 
View > Other... and selecting the desired view from the dialog that is displayed. 

NOTE: The contents of the SCM application are updated by selecting File > 
Source Control in Rational Integration Tester. There is no other way 
to refresh the view in the SCM application. 

When working in a project under SCM, it is useful to return to the SCM application 
from time to time to review any changes or conflicts that might exist (for example, if 
another user has opened the same project). To keep your current Rational Integration 
Tester project up to date, select File > Source Control and review any potential 
changes in the Synchronize view of the SCM application. If any resources in your 

Rational Integration Tester project are unsaved, click the Save All button  to save 
them. 
© Copyright IBM Corp. 2001, 2012 12 



Incoming and outgoing changes can be updated/committed using the toolbar in the 
Synchronize view. Committed changes will be reflected in the repository, and 
incoming updates will be reflected in your open Rational Integration Tester project. 
© Copyright IBM Corp. 2001, 2012 13 



 
 

 
 

 

 

 

   

 

 

   

 

2.3.1 Synchronize 

The Synchronize view displays the current project, highlighting any changes or 
conflicts that exist between the Rational Integration Tester project and the current 
version in the repository. 

The toolbar in the Synchronize view provides features that help you navigate the 
project tree and resolve differences in the project. The individual toolbar icons are 
described below: 

Icon Description 

Switch between opened projects or open/synchronize with another project.
 

Pins the current synchronization.
 

Expands the entire project tree.
 

Moves to the next difference in the project.
 

Moves to the previous difference in the project.
 

Collapses the entire project tree.
 

Incoming mode shows changes made outside of the Rational Integration Tester
 
project (for example, by other users).
 

Outgoing mode shows uncommitted changes made in your Rational Integration
 
Tester project.
 

Incoming/Outgoing mode shows incoming and outgoing changes.
 

Conflicts mode shows conflicts between the project and the repository.
 

Updates all incoming changes to the Rational Integration Tester project.
 

Commits all outgoing changes to the repository.
 

Toggles the display of change sets in the synchronization tree.
 
© Copyright IBM Corp. 2001, 2012 14 



     

 

2.3.2 Navigator 

The Navigator lets you browse the contents of all projects in the selected repository, 
showing the status of the items that each one contains. 

More information about the status icons in the Navigator can be found in the online 
help (select Help > Help Contents, then select the book for the Team Provider 
currently in use). 
© Copyright IBM Corp. 2001, 2012 15 



 

2.3.3 Console 

The Console displays status and error messages as they pertain to basic operations in 
the SCM application (for example, sharing a project, updating changes, committing 
changes, and so on). 
© Copyright IBM Corp. 2001, 2012 16 



   

2.3.4 History 

The History shows the revision history of a selected item in the Synchronize tree or 
Navigator (by right-clicking the item and selecting Show History from the context 
menu). 
© Copyright IBM Corp. 2001, 2012 17 
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additional team provider 
plugins that support different 
SCM systems. 
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3.1 Detailed Example 
The following example illustrates how to install a team provider in full detail. The 
Subclipse provider is installed in this example. 

1.	 Launch the Rational Integration Tester repository browser as described in Check In a 
Project. 

2.	 Select Help > Software Updates. 

3. In the Feature Updates window, select the second option (Search for new features 
to install) and click Next. 
© Copyright IBM Corp. 2001, 2012 19 



 

  
 

 

4.	 Select the team provider sites from which you want to search for new features and 
click Next. 

You can add your own site by clicking New Remote Site, and you can add a local site 
by clicking New Local Site (that is, a local or internal network directory) if you are 
behind a firewall or otherwise are unable to access the remote sites. Select New 
Archived Site if you have a JAR or .zip file that contains the required updates. 
© Copyright IBM Corp. 2001, 2012 20 



 

 
 

 

 

5. When the feature search is finished (based on the selected sites), select the features 
that you want to install from the list of those available, then click Next. 

NOTE:	 For SVN support using the Subclipse provider, the options illustrated 
above, including the entire Subclipse SVNKit Option, should be 
selected. The SVN kit allows Subclipse to communicate 
independently with an SVN repository (that is, there is no need for 
the user to have the SVN Client installed). 
© Copyright IBM Corp. 2001, 2012 21 



6. Review the license agreements for all of the selected features. If you agree with the 
terms of the licenses, select the I accept ... option and click Next. 

NOTE: Note, if you do not accept the terms of all displayed license 
agreements, you will not be able to continue. 
© Copyright IBM Corp. 2001, 2012 22 



 

 

7. If any optional features are available for your selected team provider, enable the ones 
that you want to install and click Next. 

8.	 Review the installation summary to ensure the desired features will be installed into 
the expected location. 

NOTE:	 The remaining steps are optional but they will enable users to avoid 
having to reinstall providers following an update to Rational 
Integration Tester. 
© Copyright IBM Corp. 2001, 2012 23 



9. Select all of the features that will be installed (select the first then select the last while 
holding the Shift key) and click Change Location. 

10. In the New Update Site window, click Add Location. 
© Copyright IBM Corp. 2001, 2012 24 



 

 

11. Use the Browse dialog to locate an existing folder or to create a new folder into 
which the team provider features can be installed. In our example, we have created a 
directory named “Subclipse” on the root of the C:\ drive. 

12. Click OK to return to the installation summary, then click Finish to install the 
selected features. 

NOTE:	 If you receive any warnings about unverified or unsigned features, you 
will have to permit their installation to continue. Otherwise you must 
cancel the installation and you will be unable to use the new team 
provider. 
© Copyright IBM Corp. 2001, 2012 25 



 

13. Click Install for each feature (or Install All to avoid any further prompts) to 
continue. 

14. Once the features are installed, you will be prompted to restart SCM in Rational 
Integration Tester – select Yes to restart the SCM component but not Rational 
Integration Tester. 
© Copyright IBM Corp. 2001, 2012 26 



 

 

15. Once the SCM component is restarted, the Share Project dialog is displayed. If you 
want to share a project using one of the installed providers, select it and click Next. 
Otherwise, click Cancel to open the repository browser and get started. 

16. If you are sharing a project, follow the steps provided (which will be the same as those 
required in the native SCM system) to set up a connection to an existing repository. 

When finished, the Synchronisation view is displayed. 

NOTE:	 The use of the repository browser is described in Using the SCM 
Application. 

For the Subclipse provider, you should set the SVN interface to SVNKit. 
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17. Select Window > Preferences, then select the SVN entry under the Team group. 
Under SVN interface, select the SVNKit option as the client. 

Once the installation of a new provider is complete, you can create a link to the 
provider in your Rational Integration Tester folder. This can help you quickly restore 
the provider if you remove and update Rational Integration Tester. 

18. Create a directory named “links” in your Rational Integration Tester installation 
directory (for example, C:\Program Files\IBM\RationalIntegrationTester). 

19. Create a text file in the new directory, the contents of which is the path to the 
provider directory (refer to step 11). In our example, the file contents would be 
path=c:/Subclipse. 

20. Save and close the file, then rename it <provider>.link (for example, 
subclipse.link). The file can have any name, as long as the extension is .link. 

21. Make a backup copy of the directory, then copy it into any new/updated Rational 
Integration Tester installation to restore the SCM links. 

NOTE:	 You can include multiple link files in the “links” folder to point to 
more than one tool. 
© Copyright IBM Corp. 2001, 2012 28 



 

 
 

 
 

 

 
  

 

 

 

 
   

 

 
 

3.2 Adding the ClearCase Provider 
This section provides information about installing the IBM Rational® ClearCase® 
Remote Client and the Graphical Editing Framework (if required). 

The Rational Integration Tester SCM application is built on the Eclipse Europa (3.3) 
release, and some team providers may be incompatible with this version. For more 
information about system requirements for the ClearCase Remote Client, see the 
following URL: 
http://www-01.ibm.com/support/docview.wss?rs=984&uid=swg21224586 

3.2.1 Installing the ClearCase Provider 

Follow the steps below to install the ClearCase team provider. 

1.	 Launch the SCM application by selecting Source Control from Rational Integration 
Tester’s File menu, and close any dialogs that prompt you for repository details. 

2.	 In the SCM application, select Help > Software Updates. 

3.	 In the Feature Updates dialog, select the Search for new features to install option 
and click Next. 

4.	 On the Update sites to visit page, click New Remote Site. 

5.	 In the New Update Site dialog, specify a name for the site in the Name field and 
specify the URL to the update (in the form http://<computer-name>/ccrc/update 
where <computer-name> is the name of the computer that has ClearCase and the CM 
Server for Rational ClearCase Remote Client installed on it. 

NOTE:	 Rational ClearCase may be installed on this computer or on a remote 
computer. 

6.	 Click OK, check the box next to the new remote site, then click Finish. 

7.	 When the feature search is finished (based on the selected sites), expand the tree 
under the new update site name and select Rational ClearCase Remote Client, then 
click Next. 

NOTE:	 If you see an error about Rational ClearCase Remote Client for 
Eclipse requiring the "org.eclipse.draw2d" plug-in, follow the 
instructions in Installing the Graphical Editing Framework (GEF) to 
install the GEF Runtime plug-in. 
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8.	 On the Feature License page, read the license agreement carefully. If you accept the 
terms, select I accept the terms in the license agreements... and then click Next. 
If you do not accept the terms, select Cancel to end the installation. 

9.	 On the Installation page, verify that the Install Location is where you want to 
install Rational ClearCase Remote Client for Eclipse. Click Change Location... to 
specify a new install location. 

10. Click Finish. You may be presented with a dialog box prompting you to verify that 
you trust the signer of the jar files in which the client is packaged. After this step, the 
Eclipse update manager installs Rational ClearCase Remote Client for Eclipse into the 
selected Eclipse installation directory and then prompts you to restart Eclipse. 

11. Restart Eclipse. 

12. Once the SCM component is restarted, the Share Project dialog is displayed. If you 
want to share a project using one of the installed providers, select it and click Next. 
Otherwise, click Cancel to open the repository browser and get started. 

13. If you are sharing a project, follow the steps provided (which will be the same as those 
required in the native SCM system) to set up a connection to an existing repository. 

When finished, the Synchronisation view is displayed. 

NOTE: The use of the synchronisation view is beyond the scope of this 
document since you should already be familiar with its use. 
© Copyright IBM Corp. 2001, 2012 30 



 

 

   

 

3.2.2 Installing the Graphical Editing Framework (GEF) 

The ClearCase team provider requires the Graphical Editing Framework before 
installing the Rational ClearCase Remote Client for Eclipse. The version of GEF 
required may not be known until you are installing ClearCase, and that depends on 
the version of the ClearCase server to which you will be connecting. 

1.	 If required, and once the GEF version is known, download the correct version from 
http://www.eclipse.org/gef/downloads. 

2.	 Download the GEF “runtime” package to a temporary location on the machine 
where Rational Integration Tester is installed. 

3.	 Extract the GEF .zip archive in the folder where the package was downloaded. 

4.	 Locate the “features” and “plugins” directories in the directory where the GEF 
archive was extracted. 

5.	 Copy the contents of each directory into the equivalent directories (that is, “features” 
and “plugins”) within your Rational Integration Tester installation. 

NOTE:	 The directories in the archive may contain both JAR files and 
directories. 

6.	 Restart Rational Integration Tester and attempt to install the ClearCase provider as 
described in Installing the ClearCase Provider. 
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Glossary
 

The following table below lists some of the key terms used in this document, and 
provides a description of each. 

Term Description 

Field A bit of data constituent to a message. Most fields are scalar and 
therefore unitary, equivalent to data attributes. Vector fields are 
an aggregation of fields both scalar and vector, and are usually 
referred to as Messages. See also Message. 

Message A unit of information made up of a header consisting of meta­
information and a body consisting of the message data. 

Host The computer on which a software process runs. 

Publisher-Subscriber A messaging paradigm whereby a messaging network consists of 
Publishers and Subscribers. 

Transport Informally, the messaging software in use. For instance, TIBCO 
Rendezvous, TIBCO ActiveEnterprise, IBM WebSphere® MQ 
(JMS). 

Publishing Making a message (data) available on a message channel. 

Subscribing Receiving a stream of messages (data) on a given message 
channel. 

Subject A user-meaningful name for identifying messages on TIBCO 
transports. For example, the subject EQ.IBM might identify all 
pricing data about IBM stocks, while EQ.IBM.N might identify price 
data from the New York Stock Exchange only. See also: JMS 
queue, JMS topic. 

Server A host computer on a network shared by more than one user. 

Subject A user-meaningful name for identifying data objects. For example, 
the subject EQ.IBM might identify all pricing data about IBM 
stocks, while EQ.IBM.N might identify price data from the New 
York Stock Exchange only. 

© Copyright IBM Corp. 2001, 2012 32 



 

 

 

 
 

 

Notices
 

This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in 
other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right may be 
used instead. However, it is the user's responsibility to evaluate and verify the 
operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you any 
license to these patents. You can send license inquiries, in writing, to: 

IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM 
Intellectual Property Department in your country or send inquiries, in writing, to: 

Intellectual Property Licensing 
Legal and Intellectual Property Law 
IBM Japan, Ltd. 
1623-14, Shimotsuruma, Yamato-shi 
Kanagawa 242-8502 Japan 

The following paragraph does not apply to the United Kingdom or any other 
country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
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MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
states do not allow disclaimer of express or implied warranties in certain transactions, 
therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements and/ 
or changes in the product(s) and/or the program(s) described in this publication at 
any time without notice. 

IBM may use or distribute any of the information you supply in any way it believes 
appropriate without incurring any obligation to you. 

Licensees of this program who wish to have information about it for the purpose of 
enabling: (i) the exchange of information between independently created programs 
and other programs (including this one) and (ii) the mutual use of the information 
which has been exchanged, should contact: 

IBM United Kingdom Limited 
Intellectual Property Law 
Hursley Park 
Winchester 
SO21 2JN 
Hampshire 
United Kingdom 

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 

The licensed program described in this document and all licensed material available 
for it are provided by IBM under terms of the IBM Customer Agreement, IBM 
International Program License Agreement or any equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. 
Therefore, the results obtained in other operating environments may vary 
significantly. Some measurements may have been made on development-level systems 
and there is no guarantee that these measurements will be the same on generally 
available systems. Furthermore, some measurements may have been estimated 
through extrapolation. Actual results may vary. Users of this document should verify 
the applicable data for their specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those 
products, their published announcements or other publicly available sources. IBM has 
not tested those products and cannot confirm the accuracy of performance, 
compatibility or any other claims related to non-IBM products. Questions on the 
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capabilities of non-IBM products should be addressed to the suppliers of those 
products. 

All statements regarding IBM’s future direction or intent are subject to change or 
withdrawal without notice, and represent goals and objectives only. 

This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual business 
enterprise is entirely coincidental. 

COPYRIGHT LICENSE: 

This information contains sample application programs in source language, which 
illustrate programming techniques on various operating platforms. You may copy, 
modify, and distribute these sample programs in any form without payment to IBM, 
for the purposes of developing, using, marketing or distributing application programs 
conforming to the application programming interface for the operating platform for 
which the sample programs are written. These examples have not been thoroughly 
tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, 
serviceability, or function of these programs. 

Each copy or any portion of these sample programs or any derivative work, must 
include a copyright notice as follows: 

© (your company name) (year). Portions of this code are derived from IBM Corp. 
Sample Programs. © Copyright IBM Corporation 2001, 2012. 

If you are viewing this information softcopy, the photographs and color illustrations 
may not appear. 
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Trademarks and service marks 
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions worldwide. 
Other product and service names might be trademarks of IBM or other companies. A 
current list of IBM trademarks is available on the Web at “Copyright and trademark 
information” at www.ibm.com/legal/copytrade.shtml. 

Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both. 

UNIX is a registered trademark of The Open Group in the United States and other 
countries. 
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